• WAP手机版 保存到桌面  加入收藏  设为首页
当前位置:首页 > 数据库

Mysql version can not be less than 4.1是数据库连不上,账号不对

时间:2015-02-13 11:59:37   作者:网钛VPS网   来源:www.v0000.com   阅读:510   评论:0
内容摘要:Mysql version can not be less than 4.1是数据库连不上,账号不对,修改下数据库配置文件,就可解决。

PHP程序移站时,若提示Mysql version can not be less than 4.1,

  这个直接翻译过来是:Mysql数据库版本不能低于4.1

  貌似是数据库版本的问题,真是Q的吗?但数据库版本已经是5.5版本了啊,因此不会是数据库版本的问题了。

  经查,竟然:

  是没有修改程序和数据库连接的配置文件,汗,这个竟然忘记了,

  才导致出现了Mysql version can not be less than 4.1。

  于是在网站根目录下或DATA目录中找到数据库配置文件 config.inc.php

  #[数据库参数]

  $dbHost="localhost";

  $dbName="test";

  $dbUser="test";

  $dbPass="123456";

  修改上面三个地方的红色部分,问题得到解决。

  注意:如果web空间的IP和数据库的IP不一致的话,还需要配置localhost为相应的数据IP

  还有一种可能,你的数据库名密码错了~这个貌似最常见

该文章所属专题:数据库教程

出处:

网钛远程桌面管理助手http://otcms.cn

网钛文章CMShttp://otcms.com

转载时请注明出处和网址

    网钛远程桌面管理助手是网钛科技旗下产品,
一款批量分组管理远程桌面账号密码和远程桌面的工具,自由切换软件自带或系统自带远程桌面模式,随心选择不同分辨率或全屏模式,实时显示ping状态,可admin强行登录连接,可映射本地硬盘,可设开机密码,靠边自动收缩。

标签:MYSQL教程  VPS教程  
相关评论

精彩推荐

联系我们 - 关于我们 - 网站地图
 企业客服QQ:800166366   QQ交流群4:137065150    OTCMS作者QQ:877873666    阿里旺旺:    闽ICP备12010380号